CCNP ROUTE EIGRP Classic+Named+IPv4+IPv6

Enviado por lesand el Mié, 05/10/2016 - 21:29
Topología
Topologia EIGRP
Resumen de la actividad:
Se realizara la configuración del protocolo EIGRP sobre una topología que contiene Frame Relay, DMVPN y MPLS. Estas configuraciones se realizaran utilizando los modos classic y named para los protocolos IPv4 e IPv6.
Objetivo(s):
Configuración EIGRP sobre Frame Relay Multipunto con definición manual de vecinos.
Configuración de sumarizacion en interfaces seriales.
Configuración de DMVPN
Modificación de opciones de Next-Hop-Self y Split Horizont en EIGRP
Protección de los túneles usando IPSEC
Recursos Utilizados:
Cisco IOS Software, 7200 Software (C7200-ADVIPSERVICESK9-M), Version 15.2(4)S5, RELEASE SOFTWARE (fc1)
Desarrollo de la actividad:
CONFIGURACIÓN DE INTERFACES MULTIPUNTO EN FRAME RELAY Y DESHABILITACION DEL ARP INVERSO
Se asignarán las direcciones IP y se configurarán las interfaces seriales como multipunto, además se des-habilitará el ARP inverso y se realizará el "mapeo" de las interfaces de forma manual (en este caso no se utilizará el comando broadcast, debido a que los vecinos se ingresaran de forma manual)
DP-S1(config)#int lo1
DP-S1(config-if)#ip add 10.1.1.1 255.255.255.0

DP-S1(config-if)#int lo2
DP-S1(config-if)#ip add 10.1.2.1 255.255.255.0

DP-S1(config-if)#int lo3
DP-S1(config-if)#ip add 10.1.3.1 255.255.255.0

DP-S1(config-if)#int Gi1/0
DP-S1(config-if)#no shut
DP-S1(config-if)#ip add 10.1.0.1 255.255.255.0

DP-S1(config-if)#int se6/0
DP-S1(config-if)#no shut
DP-S1(config-if)#ip add 172.16.2.1 255.255.255.0
DP-S1(config-if)#encapsulation frame-relay
DP-S1(config-if)#frame-relay lmi-type ansi
DP-S1(config-if)#no frame-relay inverse-arp
DP-S1(config-if)#frame-relay map ip 172.16.2.254 201
DP-S2(config)#int lo1
DP-S2(config-if)#ip add 10.2.1.1 255.255.255.0

DP-S2(config-if)#int lo2
DP-S2(config-if)#ip add 10.2.2.1 255.255.255.0

DP-S2(config-if)#int lo3
DP-S2(config-if)#ip add 10.2.3.1 255.255.255.0

DP-S2(config-if)#int Gi1/0
DP-S2(config-if)#no shut
DP-S2(config-if)#ip add 10.2.0.1 255.255.255.0

DP-S2(config-if)#int se6/0
DP-S2(config-if)#no shut
DP-S2(config-if)#ip add 172.16.2.2 255.255.255.0
DP-S2(config-if)#encapsulation frame-relay
DP-S2(config-if)#frame-relay lmi-type ansi
DP-S2(config-if)#no frame-relay inverse-arp
DP-S2(config-if)#frame-relay map ip 172.16.2.254 202
DP-S3(config)#int lo1
DP-S3(config-if)#ip add 10.3.1.1 255.255.255.0

DP-S3(config-if)#int lo2
DP-S3(config-if)#ip add 10.3.2.1 255.255.255.0

DP-S3(config-if)#int lo3
DP-S3(config-if)#ip add 10.3.3.1 255.255.255.0

DP-S3(config-if)#int Gi1/0
DP-S3(config-if)#no shut
DP-S3(config-if)#ip add 10.3.0.1 255.255.255.0

DP-S3(config-if)#int se6/0
DP-S3(config-if)#no shut
DP-S3(config-if)#ip add 172.16.2.3 255.255.255.0
DP-S3(config-if)#encapsulation frame-relay
DP-S3(config-if)#frame-relay lmi-type ansi
DP-S3(config-if)#no frame-relay inverse-arp
DP-S3(config-if)#frame-relay map ip 172.16.2.254 203
DP-H2(config)#int lo1
DP-H2(config-if)#ip add 10.200.0.1 255.255.255.0

DP-H2(config-if)#int se6/0
DP-H2(config-if)#no shut

DP-H2(config-if)#ip add 172.16.2.254 255.255.255.0
DP-H2(config-if)#encapsulation frame-relay
DP-H2(config-if)#frame-relay lmi-type ansi
DP-H2(config-if)#no frame-relay inverse-arp
DP-H2(config-if)#frame-relay map ip 172.16.2.1 21
DP-H2(config-if)#frame-relay map ip 172.16.2.2 22
DP-H2(config-if)#frame-relay map ip 172.16.2.3 23
Configuración de EIGRP AS 104 para las interfaces con IPv4
En este caso se activaran todas las interfaces y se desactivaran las actualizaciones donde no sea necesario, además se configuraran de forma manual los vecinos, para que las actualizaciones del protocolo se realicen usando unicast.
DP-S1(config)#router eigrp 104
DP-S1(config-router)#network 10.1.0.0 0.0.3.255
DP-S1(config-router)#network 172.16.2.0 0.0.0.255
DP-S1(config-router)#neighbor 172.16.2.254 se6/0
DP-S1(config-router)#passive-interface Loopback1
DP-S1(config-router)# passive-interface Loopback2
DP-S1(config-router)# passive-interface Loopback3
DP-S1(config-router)# passive-interface GigabitEthernet1/0
DP-S2(config)#router eigrp 104
DP-S2(config-router)#network 10.2.0.0 0.0.3.255
DP-S2(config-router)#network 172.16.2.0 0.0.0.255
DP-S2(config-router)#neighbor 172.16.2.254 se6/0
DP-S2(config-router)#passive-interface Loopback1
DP-S2(config-router)# passive-interface Loopback2
DP-S2(config-router)# passive-interface Loopback3
DP-S2(config-router)# passive-interface GigabitEthernet1/0
DP-S3(config)#router eigrp 104
DP-S3(config-router)#network 10.3.0.0 0.0.3.255
DP-S3(config-router)#network 172.16.2.0 0.0.0.255
DP-S3(config-router)#neighbor 172.16.2.254 se6/0
DP-S3(config-router)#passive-interface Loopback1
DP-S3(config-router)# passive-interface Loopback2
DP-S3(config-router)# passive-interface Loopback3
DP-S3(config-router)# passive-interface GigabitEthernet1/0
DP-H2(config)#router eigrp 104
DP-H2(config-router)#network 10.200.0.0 0.0.0.255
DP-H2(config-router)#network 172.16.2.0 0.0.0.255
DP-H2(config-router)#neighbor 172.16.2.1 se6/0
DP-H2(config-router)#neighbor 172.16.2.2 se6/0
DP-H2(config-router)#neighbor 172.16.2.3 se6/0
DP-H2(config-router)# passive-interface Loopback0
Visualización de los vecinos
Como se observa a continuación se pueden observar los vecinos para el router DP-H2 y para el router DP-S1. En el caso de DP-H2 recibe 4 prefijos de cada vecino y DP-S1 solo recibe 1 prefijo desde el HUB (DP-H2), esto se debe a que se ecuentra habilitado el Split-Horizont.
DP-H2#show ip eigrp neighbors detail
EIGRP-IPv4 Neighbors for AS(104)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
2 172.16.2.1 Se6/0 136 00:08:00 157 942 0 6
Static neighbor
Version 11.0/2.0, Retrans: 0, Retries: 0, Prefixes: 4
Topology-ids from peer - 0
1 172.16.2.2 Se6/0 144 00:14:18 115 690 0 4
Static neighbor
Version 11.0/2.0, Retrans: 0, Retries: 0, Prefixes: 4
Topology-ids from peer - 0
0 172.16.2.3 Se6/0 154 00:14:28 146 876 0 4
Static neighbor
Version 11.0/2.0, Retrans: 0, Retries: 0, Prefixes: 4
Topology-ids from peer - 0
DP-S1#show ip eigrp neighbors detail
EIGRP-IPv4 Neighbors for AS(104)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.2.254 Se6/0 150 00:08:57 140 840 0 13
Static neighbor
Version 11.0/2.0, Retrans: 0, Retries: 0, Prefixes: 1
Topology-ids from peer - 0
DP-H2#show ip eigrp interfaces detail ser6/0
EIGRP-IPv4 Interfaces for AS(104)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se6/0 3 0/0 0/0 139 0/15 617 0
Hello-interval is 60, Hold-time is 180
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 9/0
Hello's sent/expedited: 26/5
Un/reliable mcasts: 0/0 Un/reliable ucasts: 14/19
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Topology-ids on interface - 0
Authentication mode is not set
Deshabilitación del Split Horizont y verificación de rutas en sucursales
Se desactivará en DP-H2 (Hub) y se visualizara que los spoke (DP-S1) aprendan todos los prefijos
DP-H2(config)#int se6/0
DP-H2(config-if)#no ip split-horizon eigrp 104
DP-H2#show ip eigrp interfaces detail ser6/0
EIGRP-IPv4 Interfaces for AS(104)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se6/0 3 0/0 0/0 157 0/15 617 0
Hello-interval is 60, Hold-time is 180
Split-horizon is disabled
Next xmit serial <none>
Packetized sent/expedited: 12/2
Hello's sent/expedited: 33/5
Un/reliable mcasts: 0/0 Un/reliable ucasts: 20/22
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Topology-ids on interface - 0
Authentication mode is not set
DP-S1#show ip eigrp neighbors detail
EIGRP-IPv4 Neighbors for AS(104)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.2.254 Se6/0 131 00:20:14 152 912 0 16
Static neighbor
Time since Restart 00:02:26
Version 11.0/2.0, Retrans: 0, Retries: 0, Prefixes: 10
Topology-ids from peer - 0
DP-S1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 17 subnets, 2 masks
D 10.2.0.0/24 [90/2682112] via 172.16.2.254, 00:02:44, Serial6/0
D 10.2.1.0/24 [90/2809856] via 172.16.2.254, 00:02:44, Serial6/0
D 10.2.2.0/24 [90/2809856] via 172.16.2.254, 00:02:44, Serial6/0
D 10.2.3.0/24 [90/2809856] via 172.16.2.254, 00:02:44, Serial6/0
D 10.3.0.0/24 [90/2682112] via 172.16.2.254, 00:02:44, Serial6/0
D 10.3.1.0/24 [90/2809856] via 172.16.2.254, 00:02:44, Serial6/0
D 10.3.2.0/24 [90/2809856] via 172.16.2.254, 00:02:44, Serial6/0
D 10.3.3.0/24 [90/2809856] via 172.16.2.254, 00:02:44, Serial6/0
D 10.200.0.0/24 [90/2297856] via 172.16.2.254, 00:20:32, Serial6/0
SUmarizacion
Sumarizacion en interfaces seriales y visualización
DP-S1(config)#int se6/0
DP-S1(config-if)#ip summary-address eigrp 104 10.1.0.0 255.255.252.0
DP-S2(config-router)#int se6/0
DP-S2(config-if)#ip summary-address eigrp 104 10.2.0.0 255.255.252.0
DP-S3(config-router)#int se6/0
DP-S3(config-if)#ip summary-address eigrp 104 10.3.0.0 255.255.252.0
DP-S1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 12 subnets, 3 masks
D 10.1.0.0/22 is a summary, 00:02:57, Null0
D 10.2.0.0/22 [90/2682112] via 172.16.2.254, 00:02:41, Serial6/0
D 10.3.0.0/22 [90/2682112] via 172.16.2.254, 00:02:34, Serial6/0
D 10.200.0.0/24 [90/2297856] via 172.16.2.254, 00:26:58, Serial6/0
Configuración de DMVPN
Se asignarán las direcciones IPs en las interfaces y se configurará la ruta por defecto para la conexión al Proveedor de servicios.
Además se configuran las interfaces túnel como multipunto y se habilita NHRP para la resolución de los “next hop” y el soporte para multicast. Para este ejemplo se considerará como HUB al equipo DP-H1 y como SPOKE a los equipos DP-S1, DP-S2 y DP-S3.
Posteriormente se habilita el enrutamiento EIGRP y se configura la sumarización en las interfaces túnel.
DP-S1(config)#int g0/0
DP-S1(config-if)#no shut
DP-S1(config-if)#ip add 190.1.0.2 255.255.255.0

DP-S1(config)#ip route 0.0.0.0 0.0.0.0 190.1.0.1

DP-S1(config)#interface Tunnel0
DP-S1(config-if)#ip address 172.16.1.1 255.255.255.0
DP-S1(config-if)#tunnel source GigabitEthernet0/0
DP-S1(config-if)#tunnel mode gre multipoint
DP-S1(config-if)#ip nhrp network-id 123
DP-S1(config-if)#ip nhrp authentication DP-2016
DP-S1(config-if)#ip nhrp nhs 172.16.1.254
DP-S1(config-if)#ip nhrp map 172.16.1.254 190.200.0.2
DP-S1(config-if)#ip nhrp map multicast 190.200.0.2

DP-S1(config-if)#router eigrp 104
DP-S1(config-router)#network 172.16.1.0 0.0.0.255

DP-S1(config-router)#int t0
DP-S1(config-if)#ip summary-address eigrp 104 10.1.0.0 255.255.252.0
DP-S2(config)#int g0/0
DP-S2(config-if)#no shut
DP-S2(config-if)#ip add 190.2.0.2 255.255.255.0

DP-S2(config-if)#ip route 0.0.0.0 0.0.0.0 190.2.0.1

DP-S2(config)#interface Tunnel0
DP-S2(config-if)#ip address 172.16.1.2 255.255.255.0
DP-S2(config-if)#tunnel source GigabitEthernet0/0
DP-S2(config-if)#tunnel mode gre multipoint
DP-S2(config-if)#ip nhrp network-id 123
DP-S2(config-if)#ip nhrp authentication DP-2016
DP-S2(config-if)#ip nhrp nhs 172.16.1.254
DP-S2(config-if)#ip nhrp map 172.16.1.254 190.200.0.2
DP-S2(config-if)#ip nhrp map multicast 190.200.0.2

DP-S2(config-if)#router eigrp 104
DP-S2(config-router)#network 172.16.1.0 0.0.0.255

DP-S2(config-router)#int t0
DP-S2(config-if)#ip summary-address eigrp 104 10.2.0.0 255.255.252.0
DP-S3(config)#int g0/0
DP-S3(config-if)#no shut
DP-S3(config-if)#ip add 190.3.0.2 255.255.255.0

DP-S3(config-if)#ip route 0.0.0.0 0.0.0.0 190.3.0.1

DP-S3(config)#interface Tunnel0
DP-S3(config-if)#ip address 172.16.1.3 255.255.255.0
DP-S3(config-if)#tunnel source GigabitEthernet0/0
DP-S3(config-if)#tunnel mode gre multipoint
DP-S3(config-if)#ip nhrp network-id 123
DP-S3(config-if)#ip nhrp authentication DP-2016
DP-S3(config-if)#ip nhrp nhs 172.16.1.254
DP-S3(config-if)#ip nhrp map 172.16.1.254 190.200.0.2
DP-S3(config-if)#ip nhrp map multicast 190.200.0.2

DP-S3(config-if)#router eigrp 104
DP-S3(config-router)#network 172.16.1.0 0.0.0.255

DP-S3(config-router)#int t0
DP-S3(config-if)#ip summary-address eigrp 104 10.3.0.0 255.255.252.0
DP-H1(config)#int lo0
DP-H1(config-if)#ip add 10.100.0.1 255.255.255.0

DP-H1(config-if)#int g0/0
DP-H1(config-if)#no shut
DP-H1(config-if)#ip add 190.200.0.2 255.255.255.0

DP-H1(config-if)#ip route 0.0.0.0 0.0.0.0 190.200.0.1

DP-H1(config)#interface Tunnel0
DP-H1(config-if)#ip address 172.16.1.254 255.255.255.0
DP-H1(config-if)#tunnel source GigabitEthernet0/0
DP-H1(config-if)#tunnel mode gre multipoint
DP-H1(config-if)#ip nhrp network-id 123
DP-H1(config-if)#ip nhrp authentication DP-2016
DP-H1(config-if)#ip nhrp map multicast dynamic

DP-H1(config-if)#router eigrp 104
DP-H1(config-router)#network 172.16.1.0 0.0.0.255
DP-H1(config-router)#network 10.100.0.0 0.0.0.255
Split Horizont y Next-hop-Self en DMVPN
Se desactiva el "Split-Horizont", para que los spoke puedan visualizar las rutas entre ellos y se desactiva la opción de "Next-Hop-Self” para que la comunicación entre los spoke se realice de forma directa.
DP-H1(config)#int t0
DP-H1(config-if)#no ip split-horizon eigrp 104
DP-H1(config-if)#no ip next-hop-self eigrp 104
Más información:
CCNP Routing and Switching ROUTE 300-101 Official Cert Guide